母艦PCのサーバー環境をアップデート

  • Apache 2.0.52 (2004/09/29) → 2.0.58 (2006/05/01)
  • PHP 4.3.10(Build Dec 14 2004 17:46:48) → 5.1.2 (Build Jan 11 2006 16:35:21)

 2005年元旦に Windows の再インストールして、その時にいれた最新の Apache + PHP ですが、そのままバージョンアップせずに使い続けてきて、今となっては相当旧バージョンだったので、ゴールデンウィークということを機に最新版に入れ替えてみました。MySQL (4.0.23 – 2004/12/21) のアップデートも行いたいところですが、自作のWeb DBなスクリプトが動かなくなってしまったので、導入はちと見送りです。

 基本的に localhost 限定運用 (ルータで外部からのアクセスはシャットアウトしている)ということでバージョンアップを怠ってきたのですが、罰が当たりましたね。まあ、PHP の下位互換性うんぬんの問題は今にはじまったことじゃないですけれど(3→4でも仕様変更にあわせた修正をした記憶があるので、4→5で動かなくなるのもしょうがないのでしょうね)

ひさびさに自作 PHP スクリプトを触ってみましょうかねぇ。

12:40頃に追記

 PHP5 では MySQL 関連が初期状態で無効だったのをすっかり忘れてました。たぶん一昨年の正月にあえてPHP4にしたのも、それが理由だったんでしょうね。

 上記サイトのおかげで、既存のWebアプリ/スクリプトはすべて元通り動くようになりました。

 謎なのは phpMyAdmin 最新版(2.8.0)の「phpMyAdmin – エラー 扱えない拡張子のファイルです」メッセージかな? 2.5.5 が無事動いてるので、少し放置しておきますか。

15:30頃にさらに追記

 phpMyAdmin 2.8.0.3 の設定にてこずりましたが、Google で検索してあちこちの設定手順を読みあさって試行錯誤し、やっと動くようになりました。

 いったん昼食で一休みします。

投稿者: あさあさ

<あさあさ>だったり<あさあさみっくす>だったりする人。Twitterや.tkドメインみたいな先客がいなくてラッキーならあさあさでいくんだが、大概は既出なのでみっくすつけてみる。 _ があったりなかったりするのは、サービスの仕様によるゆれである。